ID #1046

0.1 Voraussetzungen

Contenido benötigt in der aktuellen Version mehrere Technologien, die entweder auf dem Server oder auf dem Rechner des Benutzers vorliegen müssen.

Der Server benötigt:

  • Eine laufende Web-Server-Applikation, z.B. Apache, Solaris, IIS oder Xitami
  • Eine laufende MySQL-Server-Applikation, die eine Versionsnummer höher als 3.23.37 besitzen sollte. Empfohlen: MySQL 4.x oder 5.x im Kompatibilitätsmodus
  • Unterstützung der Skriptsprache PHP in einer Version höher als 4.10b
  • Die zu PHP gehörende Grafikbibliothek GD Library in der Version 1 oder 2
  • Eine funktionierende gettext-Unterstützung
  • Etwa 12 MByte freien Festplattenspeicher für die Dateien

Für die Datenbank müssen folgende Bedingungen erfüllt sein:

  • Es ist eine Datenbank vorhanden oder der Nutzer verfügt über das Recht, eine neue Datenbank anzulegen
  • Wird eine MySQL-Datenbank in Version 5.x verwendet, muss diese für den Kompatibilitätsmodus konfiguriert sein
  • Der Datenbank-Account muss über das Recht "lock tables" verfügen
  • Bei einer Standardinstallation benötigt die Datenbank etwa 1,5 MByte Speicherkapazität

Für PHP sollten folgende Punkte beachtet werden:

  • Aktive Safe Mode- oder open_basedir-Einstellungen können im Einsatz mit Contenido zu Problemen führen
  • Option php_register_long_arrays muss aktiviert sein
  • ...

Der Administrator benötigt:

  • Einen funktionierenden Computer mit Internetanschluss
  • Sofern die Übertragung der Contenido-Dateien via FTP erfolgt, einen leistungsfähigen, aktuellen FTP-Client, der die Groß- und Kleinschreibung bei der Übertragung der Dateien nicht verändert.
    WS_FTP ist nicht (mehr) für Contenido geeignet. Empfehlung: FileZilla
  • Einen funktionierenden Browser (für die Installation: Internet Explorer, Firefox oder Mozilla, danach können m.E. auch Safari, Opera oder Konqueror verwendet werden)
  • Aktivierte JavaScript-Unterstützung
  • Standardmäßig wird der tinyMCE als Online-Editor verwendet. Dieser benötigt einen aktuellen Browser (Internet Explorer, Firefox, Safari, Opera).
  • Für die (optionale und nicht mehr empfohlene) Benutzung des SPAW-WYSIWYG-Editors wird der Microsoft Internet Explorer in einer Version von 6 oder höher benötigt.
  • Empfohlen: Zugriff auf die Datenbank via phpMyAdmin
  • Empfohlen: Kenntnisse in HTML, PHP und SQL

Der Redakteur benötigt:

  • Einen funktionierenden Computer mit Internetanschluss
  • Einen funktionierenden Browser (Internet Explorer, Firefox oder Mozilla; m.E. können auch Safari, Opera oder Konqueror verwendet werden)
  • Aktivierte JavaScript-Unterstützung
  • Standardmäßig wird der tinyMCE als Online-Editor verwendet. Dieser benötigt einen aktuellen Browser (Internet Explorer, Firefox, Safari, Opera).
  • Für die (optionale und nicht mehr empfohlene) Benutzung des SPAW-WYSIWYG-Editors wird der Microsoft Internet Explorer in einer Version von 6 oder höher benötigt.

Wichtig: Bitte deaktivieren Sie sämtliche Firewalls wie Zone Alarm, Norton Internet Security und Popup- bzw. Werbeblocker. Diese Anwendungen verhindern die ordnungsgemäße Funktion von Contenido.

Tipp: Auf Windows-Servern/XAMPP verhindert eine standardmäßige McAfee Antivirus-Installation das Versenden von E-Mails via sendmail (Konfiguration erforderlich).

Tags: -

Verwandte Artikel:

    Kommentieren nicht möglich